summaryrefslogtreecommitdiff
path: root/apache1x/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2007-06-01 13:41:28 +0000
committerStef Walter <stef@memberwebs.com>2007-06-01 13:41:28 +0000
commit31bc540962d8e52939f5dfddba02bb54a39e403d (patch)
tree56310dc23f5b9e292c47fbf7109ff969a8c0b8c3 /apache1x/Makefile.am
parent20cde33c0b943c77a7c9d8d5d9c3d9281a6b13a5 (diff)
make distcheck fixes
Diffstat (limited to 'apache1x/Makefile.am')
-rw-r--r--apache1x/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/apache1x/Makefile.am b/apache1x/Makefile.am
new file mode 100644
index 0000000..d043935
--- /dev/null
+++ b/apache1x/Makefile.am
@@ -0,0 +1,33 @@
+
+EXTRA_DIST = mod_httpauth.c
+
+DEF=
+INC=-I../ -I../common/
+
+all: mod_httpauth.so
+
+
+mod_httpauth.so: mod_httpauth.c ../common/sock_any.c
+ @APXS@ -c -Wc,-g -Wc,-O0 $(DEF) $(INC) $(LIB) mod_httpauth.c
+
+# install the DSO file into the Apache installation
+# and activate it in the Apache configuration
+install: all
+ @APXS@ -i -a -n 'httpauth' mod_httpauth.so
+
+# cleanup
+clean:
+ -rm -f mod_httpauth.o mod_httpauth.so
+
+# reload the module by installing and restarting Apache
+reload: install restart
+
+# the general Apache start/restart/stop procedures
+start:
+ @APACHECTL@ start
+restart:
+ @APACHECTL@ restart
+stop:
+ @APACHECTL@ stop
+
+