summaryrefslogtreecommitdiff
path: root/apache2x/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2006-05-10 18:05:02 +0000
committerStef Walter <stef@memberwebs.com>2006-05-10 18:05:02 +0000
commit6275f13d02b68d54b186036a2abea91150be6388 (patch)
tree9914a6f3d6752ac758d77615d4bda0189fe66484 /apache2x/Makefile.am
parentfed608073dd4d452673793de5563c04115514341 (diff)
Use autoconf properly
Diffstat (limited to 'apache2x/Makefile.am')
-rw-r--r--apache2x/Makefile.am31
1 files changed, 0 insertions, 31 deletions
diff --git a/apache2x/Makefile.am b/apache2x/Makefile.am
deleted file mode 100644
index 4b959cb..0000000
--- a/apache2x/Makefile.am
+++ /dev/null
@@ -1,31 +0,0 @@
-
-DEF=
-INC=-I../ -I../common/
-
-all: mod_httpauth.so
-
-
-mod_httpauth.so: mod_httpauth.c ../common/sock_any.c
- $(APXS) -c -Wc,-g -Wc,-O0 $(DEF) $(INC) $(LIB) mod_httpauth.c
- $(SH_LINK) -rpath $(libexecdir) -module -avoid-version mod_httpauth.lo
-
-# install the DSO file into the Apache installation
-# and activate it in the Apache configuration
-install: all
- $(APXS) -i -a -c -Wc,-g -Wc,-O0 $(DEF) $(INC) $(LIB) mod_httpauth.c
-
-# cleanup
-clean:
- -rm -f mod_httpauth.o mod_httpauth.so
-
-# reload the module by installing and restarting Apache
-reload: install restart
-
-# the general Apache start/restart/stop procedures
-start:
- $(APACHECTL) start
-restart:
- $(APACHECTL) restart
-stop:
- $(APACHECTL) stop
-