summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2007-05-25 16:35:40 +0000
committerStef Walter <stef@memberwebs.com>2007-05-25 16:35:40 +0000
commit5763a98bdac994a8c2ddbd693d36cbb75b1ce987 (patch)
tree677dd873096983bd06f1364a637863b75e56caf4 /configure.in
parentae3e43d0cf6014aa150c45102262819118114e94 (diff)
Build improvements
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 96ffeec..75798b5 100644
--- a/configure.in
+++ b/configure.in
@@ -179,16 +179,24 @@ fi
AC_PATH_PROG(APXS, apxs, "failed")
if test "$APXS" = "failed"; then
- AC_PATH_PROG(APXS2, apxs2, "apxs")
- APXS=$APXS2
+ AC_PATH_PROG(APXS2, apxs2, "failed")
+ if test "$APXS2" = "failed"; then
+ APXS="apxs"
+ else
+ APXS=$APXS2
+ fi
fi
AC_SUBST(APXS)
AC_PATH_PROG(APACHECTL, apachectl, "failed")
if test "$APACHECTL" = "failed"; then
- AC_PATH_PROG(APACHE2CTL, apache2ctl, "apachectl")
- APACHECTL=$APACHE2CTL
+ AC_PATH_PROG(APACHE2CTL, apache2ctl, "failed")
+ if test "$APACHE2CTL" = "failed"; then
+ APACHECTL="apachectl"
+ else
+ APACHECTL=$APACHE2CTL
+ fi
fi
AC_SUBST(APACHECTL)