summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2004-08-17 20:59:04 +0000
committerStef Walter <stef@memberwebs.com>2004-08-17 20:59:04 +0000
commitd92564c87818157b09ddfbf3314406b765ca390a (patch)
treedc37024dded77c30d769852cce0952f1b886f36c /daemon/Makefile.am
parent4af582bf3aa65e0a4ebb5723047c4d1e94d12f15 (diff)
- Changed 'goto finally' to RETURN(xx)
- Added MYSQL support and tested it.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index db83f8b..e4eecde 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -12,6 +12,8 @@ LDAP_SOURCES = ldap.c
PGSQL_SOURCES = pgsql.c
+MYSQL_SOURCES = mysql.c
+
NTLM_SOURCES = ntlm.c ntlmssp.h ntlmssp.c \
smblib/smblib.c smblib/smblib-util.c smblib/file.c smblib/smb-errors.c \
smblib/exper.c smblib/smblib-api.c smblib/smblib.h smblib/std-defines.h \
@@ -32,8 +34,12 @@ if WITH_PGSQL
httpauthd_SOURCES += $(PGSQL_SOURCES)
endif
+if WITH_MYSQL
+httpauthd_SOURCES += $(MYSQL_SOURCES)
+endif
+
httpauthd_CFLAGS = -D_THREAD_SAFE -pthread -DLinux \
-I${top_srcdir}/common/ -I${top_srcdir}
httpauthd_LDFLAGS = -pthread
-EXTRA_DIST = $(LDAP_SOURCES) $(NTLM_SOURCES) $(PGSQL_SOURCES)
+EXTRA_DIST = $(LDAP_SOURCES) $(NTLM_SOURCES) $(PGSQL_SOURCES) $(MYSQL_SOURCES)