summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2006-05-10 17:31:32 +0000
committerStef Walter <stef@memberwebs.com>2006-05-10 17:31:32 +0000
commite593016a80ceee52b6e3244512ff4307f8c208fa (patch)
tree1c3d31e8175979443f00694834bcc10ece665826 /daemon/Makefile.am
parent70488f63f5caf792ea9bf75004a3ea7a43ab90a4 (diff)
Add NTLM support.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am18
1 files changed, 12 insertions, 6 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 0e871fa..7c18b49 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -7,12 +7,18 @@ PGSQL_SOURCES = pgsql.c
MYSQL_SOURCES = mysql.c
+NTLM_SOURCES = ntlm.c ntlmssp.h ntlmssp.c
+
EXTRA_SRC =
if WITH_LDAP
EXTRA_SRC += $(LDAP_SOURCES)
endif
+if WITH_NTLM
+EXTRA_SRC += $(NTLM_SOURCES)
+endif
+
if WITH_PGSQL
EXTRA_SRC += $(PGSQL_SOURCES)
endif
@@ -22,14 +28,14 @@ EXTRA_SRC += $(MYSQL_SOURCES)
endif
httpauthd_SOURCES = httpauthd.c httpauthd.h usuals.h bd.h bd.c misc.c basic.h basic.c \
- digest.h digest.c defaults.h simple.c dummy.c \
+ digest.h digest.c defaults.h simple.c dummy.c \
../common/compat.h ../common/compat.c ../common/buffer.h ../common/buffer.c \
- ../common/hash.h ../common/hash.c ../common/md5.h ../common/md5.c \
- ../common/sha1.h ../common/sha1.c ../common/sock_any.c ../common/sock_any.h \
- ../common/stringx.c ../common/stringx.h $(EXTRA_SRC)
+ ../common/hash.h ../common/hash.c ../common/md5.h ../common/md5.c \
+ ../common/sha1.h ../common/sha1.c ../common/sock_any.c ../common/sock_any.h \
+ ../common/stringx.c ../common/stringx.h $(EXTRA_SRC)
httpauthd_CFLAGS = -D_THREAD_SAFE -pthread -DLinux \
- -I${top_srcdir}/common/ -I${top_srcdir}
+ -I${top_srcdir}/common/ -I${top_srcdir}
httpauthd_LDFLAGS = -pthread
-EXTRA_DIST = $(LDAP_SOURCES) $(PGSQL_SOURCES) $(MYSQL_SOURCES)
+EXTRA_DIST = $(LDAP_SOURCES) $(NTLM_SOURCES) $(PGSQL_SOURCES) $(MYSQL_SOURCES)