summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2006-05-10 22:02:48 +0000
committerStef Walter <stef@memberwebs.com>2006-05-10 22:02:48 +0000
commitd84dd680e0e0929406e7a70348689adbbacb3707 (patch)
tree7158a6299dd2ef3f771af8fe2c6b168032b3cb3d /doc/Makefile.am
parent977b4db32cde91d043562e9bafedbc563b6ae464 (diff)
Add HTML generation for man pages
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 85f98bc..b91c7d3 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,9 +1,16 @@
man_MANS = httpauthd.8 httpauthd.conf.5 mkha1.8
+# Simple way to make docs
+html:
+ perl man2html.pl httpauthd.8 > httpauthd.8.html
+ perl man2html.pl httpauthd.conf.5 > httpauthd.conf.5.html
+ perl man2html.pl mkha1.8 > mkha1.8.html
+
EXTRA_DIST = protocol.txt \
httpauthd.conf.sample \
ldap-example.conf \
mysql-example.conf \
ntlm-example.conf \
+ man2html.pl \
${man_MANS}