summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 39a0532..6c9ef72 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -8,7 +8,8 @@ httpauthd_SOURCES = httpauthd.c httpauthd.h usuals.h compat.h compat.c \
smblib/smblib.c smblib/smblib-util.c smblib/file.c smblib/smb-errors.c smblib/exper.c smblib/smblib-api.c \
rfcnb/rfcnb-io.c rfcnb/rfcnb-util.c rfcnb/session.c
-httpauthd_CFLAGS = -DLinux -I../common/ -I../
+httpauthd_CFLAGS = -D_THREAD_SAFE -pthread -DLinux \
+ -I${top_srcdir}/common/ -I${top_srcdir}
+httpauthd_LDFLAGS = -pthread
-# man_MANS = rtfm.1
-EXTRA_DIST = protocol.txt smblib rfcnb
+EXTRA_DIST = smblib rfcnb