summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am22
1 files changed, 12 insertions, 10 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 3c22d10..0e871fa 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -1,31 +1,33 @@
sbin_PROGRAMS = httpauthd
-httpauthd_SOURCES = httpauthd.c httpauthd.h usuals.h bd.h bd.c misc.c basic.h basic.c \
- digest.h digest.c defaults.h simple.c \
- ../common/compat.h ../common/compat.c ../common/buffer.h ../common/buffer.c \
- ../common/hash.h ../common/hash.c ../common/md5.h ../common/md5.c \
- ../common/sha1.h ../common/sha1.c ../common/sock_any.c ../common/sock_any.h \
- ../common/stringx.c ../common/stringx.h
-
LDAP_SOURCES = ldap.c
PGSQL_SOURCES = pgsql.c
MYSQL_SOURCES = mysql.c
+EXTRA_SRC =
+
if WITH_LDAP
-httpauthd_SOURCES += $(LDAP_SOURCES)
+EXTRA_SRC += $(LDAP_SOURCES)
endif
if WITH_PGSQL
-httpauthd_SOURCES += $(PGSQL_SOURCES)
+EXTRA_SRC += $(PGSQL_SOURCES)
endif
if WITH_MYSQL
-httpauthd_SOURCES += $(MYSQL_SOURCES)
+EXTRA_SRC += $(MYSQL_SOURCES)
endif
+httpauthd_SOURCES = httpauthd.c httpauthd.h usuals.h bd.h bd.c misc.c basic.h basic.c \
+ digest.h digest.c defaults.h simple.c dummy.c \
+ ../common/compat.h ../common/compat.c ../common/buffer.h ../common/buffer.c \
+ ../common/hash.h ../common/hash.c ../common/md5.h ../common/md5.c \
+ ../common/sha1.h ../common/sha1.c ../common/sock_any.c ../common/sock_any.h \
+ ../common/stringx.c ../common/stringx.h $(EXTRA_SRC)
+
httpauthd_CFLAGS = -D_THREAD_SAFE -pthread -DLinux \
-I${top_srcdir}/common/ -I${top_srcdir}
httpauthd_LDFLAGS = -pthread