Man Page: jstart(8)
jstart(8) BSD System Manager's Manual jstart(8)
jstart - start a jail
jstart path hostname ip-number [command ...]
The jstart utility starts a jail. It is a more secure replacement for the
jail(8) command. See the jail(8) man page for details on how to setup a
jail, and jail concepts.
jstart purges down the environment before running the command inside the
jail in order to prevent information leakage into the jail. If this is
not desired, then use the jail(8) command.
path Directory which is to be the root of the jail.
hostname Hostname of the prison.
ip-number IP number assigned to the prison.
command Optional command to be executed inside the jail. When not
specified this defaults to /bin/sh /etc/rc
jstart always runs as root, and runs command as root. If this is not
desired, use jail(8) with the -u option.
The command called must be owned by root in order to be executed.
The environment is purged properly before running the scripts in the jail
in order to prevent unwanted information from leaking into the jail.
jail(2), jail(8), jails(8)
Stef Walter <firstname.lastname@example.org>
jstart May 19, 2004 jstart