Man Page: injail(8)
INJAIL(8) BSD System Manager's Manual INJAIL(8)
injail - determine if a process is running in a jail
The injail utility returns a result which indicates the jailed status of
the current process environment.
The injail utility exits with one of the following values:
0 the process is running in a jail.
1 the process is not running in a jail.
2 an error prevented determining if the process is running in a
injail uses kvm_getprocs(3) to determine process status. Anything which
could cause a failure in either kvm_open(3) or kvm_getprocs(3) can cause
this to fail as well. There aught to be a cleaner way.
James E. Quick <firstname.lastname@example.org>
jails(8), jail(8), jls(8), kvm(3)
BSD May 28, 2002 BSD