Man Page: jps(8)
jps(8) BSD System Manager's Manual jps(8)
jps - prints processes running in a jail
jps -i jail
jps jail [ps-options ...]
The jps utility prints out a list of the processes running in a given
jail. When run with the -i argument it just prints out the process ids.
Otherwise it prints out a full ps(1) type listing for the processes in
the jail. The ps(1) formatting and other options are available for use.
-i Only print out the process ids.
jail Either a jail id (which is an integer) or a jail host
ps-options Formatting and other to be passed to ps(1) when listing
processes in the jail.
It is possible to run two jails with the same host name. jps however
always only prints out processes for one jail.
The environment is purged properly before running ps(1) in the jail in
order to prevent unwanted information from leaking into the jail.
jps needs a valid /dev/null device in the jail. If it doesn't exit for
some reason it is automatically created.
jail(8), jails(8), jls(8), jstart(8), ps(1)
Stef Walter <email@example.com>
jps December 9, 2004 jps