Man Page: jstart(8)
jstart(8) BSD System Manager's Manual jstart(8)
jstart - start a jail
jstart [-i] path hostname ip-number [command ...]
The jstart utility starts a jail. It is a more secure replacement for the
jail(8) command. See the jail(8) man page for details on how to setup a
jail, and jail concepts.
See the NOTES section for how how exactly jstart differs from the jail(8)
-i Print the jail identifier of the newly created jail.
path Directory which is to be the root of the jail.
hostname Hostname of the prison.
ip-number IP number assigned to the prison.
command Optional command to be executed inside the jail. When not
specified this defaults to /bin/sh /etc/rc
jstart always runs as root, and runs command as root.
jstart logs the startup to the jail's console if one exists.
The command called must be owned by root in order to be executed.
The environment is purged properly before running the scripts in the jail
in order to prevent unwanted information from leaking into the jail.
jstart works well for jails that are of the 'virtual system image' type,
which act like a full FreeBSD system. If any of the above functionality
is not desired in your case, use jail(8) command.
jail(2), jail(8), jails(8), jls(8), jexec(8), jkill(8)
Stef Walter <email@example.com>
jstart May 19, 2004 jstart