summaryrefslogtreecommitdiff
path: root/apache2x/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2006-05-10 17:31:32 +0000
committerStef Walter <stef@memberwebs.com>2006-05-10 17:31:32 +0000
commite593016a80ceee52b6e3244512ff4307f8c208fa (patch)
tree1c3d31e8175979443f00694834bcc10ece665826 /apache2x/Makefile.am
parent70488f63f5caf792ea9bf75004a3ea7a43ab90a4 (diff)
Add NTLM support.
Diffstat (limited to 'apache2x/Makefile.am')
-rw-r--r--apache2x/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/apache2x/Makefile.am b/apache2x/Makefile.am
new file mode 100644
index 0000000..4b959cb
--- /dev/null
+++ b/apache2x/Makefile.am
@@ -0,0 +1,31 @@
+
+DEF=
+INC=-I../ -I../common/
+
+all: mod_httpauth.so
+
+
+mod_httpauth.so: mod_httpauth.c ../common/sock_any.c
+ $(APXS) -c -Wc,-g -Wc,-O0 $(DEF) $(INC) $(LIB) mod_httpauth.c
+ $(SH_LINK) -rpath $(libexecdir) -module -avoid-version mod_httpauth.lo
+
+# install the DSO file into the Apache installation
+# and activate it in the Apache configuration
+install: all
+ $(APXS) -i -a -c -Wc,-g -Wc,-O0 $(DEF) $(INC) $(LIB) mod_httpauth.c
+
+# cleanup
+clean:
+ -rm -f mod_httpauth.o mod_httpauth.so
+
+# reload the module by installing and restarting Apache
+reload: install restart
+
+# the general Apache start/restart/stop procedures
+start:
+ $(APACHECTL) start
+restart:
+ $(APACHECTL) restart
+stop:
+ $(APACHECTL) stop
+