summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2004-08-12 00:50:29 +0000
committerStef Walter <stef@memberwebs.com>2004-08-12 00:50:29 +0000
commit86e45cfbd0655193e363be6daadbfd5434566a03 (patch)
tree5391fdcbfd6b3e360d425f0bd4b260d073901a21 /configure.in
parentc44a74e52a8b227857f28289a91d126b7edc959c (diff)
- Added postgresql database support
- Lots of changes to properly abstract bd handlers - Handle multiple passwords and ha1s properly.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5b0a37e..6fc6add 100644
--- a/configure.in
+++ b/configure.in
@@ -114,6 +114,24 @@ if test -n "$with_ldap"; then
AC_DEFINE_UNQUOTED(WITH_LDAP, 1, [With LDAP Support] )
fi
+# PGSQL support
+AM_CONDITIONAL(WITH_PGSQL, test -n "$with_pgsql")
+if test -n "$with_pgsql"; then
+
+ echo "enabling PGSQL support"
+
+ if test "$with_pgsql" != "yes"; then
+ LDFLAGS="$LDFLAGS -L$with_pgsql/lib"
+ CFLAGS="$CFLAGS -L$with_pgsql/include"
+ fi
+
+ AC_CHECK_LIB([pq], [PQexec], ,
+ [ echo "ERROR: Postgres libpq library required."; exit 1] )
+
+ AC_CHECK_HEADERS(libpq-fe.h)
+ AC_DEFINE_UNQUOTED(WITH_PGSQL, 1, [With PGSQL Support] )
+fi
+
# NTLM Support
AM_CONDITIONAL(WITH_NTLM, test -n "$enable_ntlm")
if test -n "$enable_ntlm"; then