summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2008-03-14 14:40:47 +0000
committerStef Walter <stef@memberwebs.com>2008-03-14 14:40:47 +0000
commit8865f7a28e40b82f98e944c8e7dbd67b56428bbc (patch)
tree1b51a96d8158b0758c304a7b72ff9c6d0cb2e533 /tests/Makefile.am
parent106dadfb63b371a1d5cf97ead46f975848e73786 (diff)
Add unit tests
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..75719b1
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,31 @@
+
+UNIT_TESTS = \
+ unit-test-ntlmssp.c
+
+INCLUDES= \
+ -I$(top_srcdir) \
+ -I$(top_builddir)
+
+noinst_PROGRAMS= \
+ run-tests
+
+run-tests.c: $(UNIT_TESTS) prep-tests.sh Makefile.am
+ sh prep-tests.sh -b run-tests $(UNIT_TESTS)
+
+run_tests_SOURCES = \
+ run-tests.c \
+ run-tests.h \
+ $(UNIT_TESTS)
+
+EXTRA_DIST = \
+ prep-tests.sh \
+ cu-test \
+ test-helpers.c \
+ test-helpers.h
+
+# ------------------------------------------------------------------------------
+# Run the tests
+
+run: $(noinst_PROGRAMS)
+ ./run-tests
+