summaryrefslogtreecommitdiff
path: root/apache2x/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'apache2x/Makefile.am')
-rw-r--r--apache2x/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/apache2x/Makefile.am b/apache2x/Makefile.am
new file mode 100644
index 0000000..a1396c4
--- /dev/null
+++ b/apache2x/Makefile.am
@@ -0,0 +1,32 @@
+
+EXTRA_DIST = mod_httpauth.c
+
+DEF=
+INC=-I../ -I../common/
+
+all: mod_httpauth.so
+
+
+mod_httpauth.so: mod_httpauth.c ../common/sock_any.c
+ @APXS@ -c -Wc,-g -Wc,-O0 $(DEF) $(INC) $(LIB) mod_httpauth.c
+
+# install the DSO file into the Apache installation
+# and activate it in the Apache configuration
+install: all
+ @APXS@ -i -a -c -Wc,-g -Wc,-O0 $(DEF) $(INC) $(LIB) mod_httpauth.c
+
+# cleanup
+clean:
+ -rm -f mod_httpauth.o mod_httpauth.so
+
+# reload the module by installing and restarting Apache
+reload: install restart
+
+# the general Apache start/restart/stop procedures
+start:
+ @APACHECTL@ start
+restart:
+ @APACHECTL@ restart
+stop:
+ @APACHECTL@ stop
+