summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2009-06-18 17:12:25 +0000
committerStef Walter <stef@memberwebs.com>2009-06-18 17:12:25 +0000
commit543b45ab3ed3f4d1a9852ead27becf0f2dee8f6d (patch)
tree00a56400bbed9e01b569e09f87eb679c5dbc8d86 /tests/Makefile.am
parent4bf87cb9f4f6b9812c06a8d2c500869c48ebc2dc (diff)
Make tests for storage, and fix problems
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..fc04b47
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,36 @@
+
+UNIT_TESTS = \
+ unit-test-storage.c
+
+INCLUDES= \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(APR_CFLAGS) \
+ $(OPKELE_CFLAGS)
+
+noinst_PROGRAMS= \
+ run-tests
+
+run-tests.c: $(UNIT_TESTS) prep-tests.sh Makefile.am
+ sh prep-tests.sh -b run-tests $(UNIT_TESTS)
+
+run_tests_SOURCES = \
+ run-tests.c \
+ run-tests.h \
+ $(UNIT_TESTS)
+
+run_tests_LDADD = \
+ $(APR_LIBS)
+
+EXTRA_DIST = \
+ prep-tests.sh \
+ cu-test \
+ test-helpers.c \
+ test-helpers.h
+
+# ------------------------------------------------------------------------------
+# Run the tests
+
+run: $(noinst_PROGRAMS)
+ ./run-tests
+