summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index bcbc312..56de6db 100644
--- a/configure.in
+++ b/configure.in
@@ -121,7 +121,8 @@ AC_ARG_ENABLE(debug,
[Compile binaries in debug mode]))
if test "$enable_debug" = "yes"; then
- CFLAGS="$CFLAGS -g -O0 -Wall -Werror"
+ CFLAGS="-Wall -Werror $CFLAGS -g -O0"
+ CXXFLAGS="-Wall -Werror $CXXFLAGS -g -O0"
AC_DEFINE_UNQUOTED(_DEBUG, 1, [In debug mode])
echo "enabling debug compile mode"
fi