summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in97
1 files changed, 97 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..de38bd9
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,97 @@
+dnl
+dnl Copyright (c) 2009, Stefan Walter
+dnl All rights reserved.
+dnl
+dnl Redistribution and use in source and binary forms, with or without
+dnl modification, are permitted provided that the following conditions
+dnl are met:
+dnl
+dnl * Redistributions of source code must retain the above
+dnl copyright notice, this list of conditions and the
+dnl following disclaimer.
+dnl * Redistributions in binary form must reproduce the
+dnl above copyright notice, this list of conditions and
+dnl the following disclaimer in the documentation and/or
+dnl other materials provided with the distribution.
+dnl * The names of contributors to this software may not be
+dnl used to endorse or promote products derived from this
+dnl software without specific prior written permission.
+dnl
+dnl THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+dnl "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+dnl LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+dnl FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+dnl COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+dnl INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+dnl BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
+dnl OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
+dnl AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+dnl OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
+dnl THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
+dnl DAMAGE.
+dnl
+dnl
+dnl CONTRIBUTORS
+dnl Stef Walter <stef@memberwebs.com>
+dnl
+
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(mod_auth_singleid, 0.1, stef@memberwebs.com)
+AM_INIT_AUTOMAKE(mod_auth_singleid, 0.1)
+
+AC_CONFIG_SRCDIR([module/mod_auth_singleid.c])
+AM_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+
+# APACHE Build stuff
+
+AC_PATH_PROG(APXS, apxs, "failed")
+if test "$APXS" = "failed"; then
+ AC_PATH_PROG(APXS2, apxs2, "failed")
+ if test "$APXS2" = "failed"; then
+ APXS="apxs"
+ else
+ APXS=$APXS2
+ fi
+fi
+
+AM_CONDITIONAL(MANUAL_BUILD, false)
+AC_SUBST(APXS)
+
+AC_PATH_PROG(APACHECTL, apachectl, "failed")
+if test "$APACHECTL" = "failed"; then
+ AC_PATH_PROG(APACHE2CTL, apache2ctl, "failed")
+ if test "$APACHE2CTL" = "failed"; then
+ APACHECTL="apachectl"
+ else
+ APACHECTL=$APACHE2CTL
+ fi
+fi
+
+AC_SUBST(APACHECTL)
+
+AC_DEFINE_UNQUOTED(CONF_PREFIX, "`eval echo ${sysconfdir}`", [Installation Prefix] )
+
+# Debug mode
+AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],
+ [Compile binaries in debug mode]))
+
+if test "$enable_debug" = "yes"; then
+ CFLAGS="$CFLAGS -g -O0 -Wall"
+ AC_DEFINE_UNQUOTED(_DEBUG, 1, [In debug mode])
+ echo "enabling debug compile mode"
+fi
+
+AC_CONFIG_FILES([
+ Makefile
+ module/Makefile
+])
+
+AC_OUTPUT
+