summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..fc04b47
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,36 @@
+
+UNIT_TESTS = \
+ unit-test-storage.c
+
+INCLUDES= \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(APR_CFLAGS) \
+ $(OPKELE_CFLAGS)
+
+noinst_PROGRAMS= \
+ run-tests
+
+run-tests.c: $(UNIT_TESTS) prep-tests.sh Makefile.am
+ sh prep-tests.sh -b run-tests $(UNIT_TESTS)
+
+run_tests_SOURCES = \
+ run-tests.c \
+ run-tests.h \
+ $(UNIT_TESTS)
+
+run_tests_LDADD = \
+ $(APR_LIBS)
+
+EXTRA_DIST = \
+ prep-tests.sh \
+ cu-test \
+ test-helpers.c \
+ test-helpers.h
+
+# ------------------------------------------------------------------------------
+# Run the tests
+
+run: $(noinst_PROGRAMS)
+ ./run-tests
+