summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2005-09-08 16:42:48 +0000
committerStef Walter <stef@memberwebs.com>2005-09-08 16:42:48 +0000
commit9a52321f7a775b6ccb15fa0cdec791614db3dc94 (patch)
tree00cf09306fe31c66b839c8c0b61de77de65c50ec /configure.in
parentf2de0ff5f1ae1cadf8693d91a3e323df8900a346 (diff)
Bring some Solaris changes over from ClamSMTP.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5dc2d93..84c6c51 100644
--- a/configure.in
+++ b/configure.in
@@ -66,12 +66,16 @@ fi
ACX_PTHREAD( , [echo "ERROR: Pthread support not found."; exit 1] )
LIBS="$PTHREAD_LIBS $LIBS"
-CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+CFLAGS="$CFLAGS $PTHREAD_CFLAGS -D_POSIX_PTHREAD_SEMANTICS"
+
+# Some checks for Solaris
+AC_CHECK_LIB(socket, getsockname)
+AC_CHECK_LIB(nsl, getaddrinfo)
# Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS(limits.h,,)
-AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h err.h string.h], ,
+AC_CHECK_HEADERS([limits.h err.h paths.h],,)
+AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h string.h netdb.h], ,
[echo "ERROR: Required C header missing"; exit 1])
# Check for linux type transparent proxy support