summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8670881..934aa31 100644
--- a/configure.in
+++ b/configure.in
@@ -2,16 +2,36 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(rrdui, 0.2.1, nielsen@memberwebs.com)
AM_INIT_AUTOMAKE(rrdui, 0.2.1)
-AC_CONFIG_SRCDIR([html/index.html])
+LDFLAGS="$LDFLAGS -L/usr/local/lib"
+CFLAGS="$CFLAGS -I/usr/local/include"
+
+AC_CONFIG_SRCDIR([tools/rrdui-cgi.c])
AM_CONFIG_HEADER([config.h])
+CFLAGS="$CFLAGS -Wall"
+
+# Debug mode
+AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],
+ [Compile binaries in debug mode]))
+
+if test "$enable_debug" = "yes"; then
+ CFLAGS="$CFLAGS -g -O0"
+ AC_DEFINE_UNQUOTED(_DEBUG, 1, [In debug mode])
+ echo "enabling debug compile mode"
+fi
+
dnl Check for programs.
+AC_PROG_CC
AC_PROG_INSTALL
+AC_PROG_RANLIB
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_C_INLINE
+AC_HEADER_STDC
+
AC_MSG_RESULT()
AC_CONFIG_FILES([Makefile tools/Makefile])