summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d17e554..f366211 100644
--- a/configure.in
+++ b/configure.in
@@ -87,6 +87,15 @@ if test "$enable_debug" = "yes"; then
echo "enabling debug compile mode"
fi
+# Log to syslog
+AC_ARG_WITH(syslog,
+ AC_HELP_STRING([--without-syslog],
+ [Don't log to syslog in addition to slapd logs]))
+
+if test "$with_syslog" != "no"; then
+ AC_DEFINE_UNQUOTED(WITH_SYSLOG, 1, [With syslog logging])
+fi
+
AC_CONFIG_FILES([
Makefile
plugin/Makefile