Man Page: rrdbot-create(8)
rrdbot-create(8) BSD System Manager's Manual rrdbot-create(8)
rddbot-create - create the RRD files for rrdbotd(8) to write values to.
rddbot-create [-nv] [-c confdir] [-w workdir]
rrdbotd(8) is an SNMP polling daemon. It writes out the polled values to
an rrdtool(1) database. The rddbot-create tool can create those RRD files
rddbot-create uses configuration files, one per RRD, to determine where
and how to do its work. Details of these files and which settings to put
in them are found in the rrdbot.conf(5) manual under the CREATE SECTION
By default th RRD files are created in the default work directory (see
the FILE LOCATIONS section below). Files that already exist are not over-
written or modified in any way.
You can use the -n option to see the rrdtool(1) commands that would be
executed. This is useful if you want to customize the commands before
The options are as follows.
-c confdir The directory in which configuration files are stored. See
below for info on the various file locations.
-n Rather than create the files, print the rrdtool(1) commands
that would be used to create the files.
-v Print verbose messages.
-V Prints the version of rddbot-create and the locations of the
configuration files, RRD files etc.
-w workdir The default directory where to look for RRD files. See below
for info on the various file locations.
To determine the default location for the configuration files and RRD
files run this command:
# rrdbotd -V
The configuration files for SNMP pollers are laid out in a directory
tree, with one file per RRD. Subdirectories can be used to organize the
configuration files. The contents of the configuration files are
described in rrdbot.conf(5).
By default the RRD files mirror the directory structure and names of the
configuration files, with an .rrd extension appended to the filename.
For example if your configuration files are in a structure like the fol-
Then the default RRD files would be in a similar directory structure:
The default location for an RRD file can be overridden by using the rrd
option in the configuration file.
rrdbotd(8), rrdbot.conf(5), rrdbot-get(1), rrdtool(1)
Stef Walter <email@example.com>
rrdbot April 16, 2008 rrdbot