Man Page: rrdbotd(8)
rrdbotd(8) BSD System Manager's Manual rrdbotd(8)
rddbotd - an SNMP poller which writes to an round robin database
rddbotd [-M] [-c confdir] [-w workdir] [-m mibdir] [-d debuglevel]
[-p pidfile] [-r retries] [-t timeout]
rddbotd is an SNMP polling daemon which writes the polled values to an
rrdtool(1) RRD database. An can poll many different SNMP sources in an
Table queries are supported, where the OID index of a certain value is
not known beforehand, or may change regularly.
In addition multiple SNMP agents may be specified for a certain value. If
one SNMP agent cannot be contacted or errors for some reason, another one
will be tried.
The configuration (eg: SNMP sources, polling intervals) are located in
files in a directory, with one configuration file per RRD. The format of
the configuration files are described in: rrdbot.conf(5)
The options are as follows.
-c confdir The directory in which configuration files are stored. See
below for info on the various file locations.
Don't detach from the console and run as a daemon. In addi-
tion the debuglevel argument specifies what level of error
messages to display. 0 being the least, 4 the most.
-m mibdir The directory in which to look for MIB files. The default
directory is usually sufficient.
-M Display MIB parsing warnings.
-p pidfile Specifies a location for the a process id file to be written
to. This file contains the process id of rddbotd and can be
used to stop the daemon.
-r retries The number of times to retry sending an SNMP packet. Defaults
to 3 retries.
-t timeout The amount of time (in seconds) to wait for an SNMP response.
Defaults to 5 seconds.
-V Prints the version of rddbotd and the locations of the con-
figuration files, RRD files etc.
-w workdir The default directory where to look for RRD files. See below
for info on the various file locations.
To determine the default location for the configuration files and RRD
files run this command:
# rrdbotd -V
The configuration files for SNMP pollers are laid out in a directory
tree, with one file per RRD. Subdirectories can be used to organize the
configuration files. The contents of the configuration files are
described in rrdbot.conf(5).
By default the RRD files mirror the directory structure and names of the
configuration files, with an .rrd extension appended to the filename.
For example if your configuration files are in a structure like the fol-
Then the default RRD files would be in a similar directory structure:
The default location for an RRD file can be overridden by using the rrd
option in the configuration file.
You can use the rrdbot-create(8) tool to create the needed RRD files in
the appropriate places.
rrdbot.conf(5), rrdbot-create(8), rrdbot-get(1), rrdtool(1)
Stef Walter <firstname.lastname@example.org>
rrdbot April 16, 2008 rrdbot