summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2009-10-29 01:41:02 +0000
committerStef Walter <stef@memberwebs.com>2009-10-29 01:41:02 +0000
commitbc97679627a6b73a8c951bca754c9445774f598b (patch)
treea0ac5c8264489b3a9befceafab67da1b9b6d3265 /Makefile.am
parent608954afbd2dd93b1ae9d7cc59a77e1ae03dfd03 (diff)
Work better with git and other tools.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8cbbd5d..8286fbb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,16 @@
SUBDIRS = module tools doc
-
dist-hook:
- rm -rf `find $(distdir)/ -name .svn`
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generate automatically. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat --date=short ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi