summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2006-03-07 00:11:27 +0000
committerStef Walter <stef@memberwebs.com>2006-03-07 00:11:27 +0000
commit28262d8b7dc5262ed9ef3a1e3d1d5662701e24ba (patch)
tree124cfd4c274c6f4b84869f4b0301945b56215ccd /configure.in
Initial import
y
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in42
1 files changed, 42 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..fb24345
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,42 @@
+# Process this file with autoconf to produce a configure script.
+AC_INIT(bsnmp-regex, 0.1, nielsen@memberwebs.com)
+AM_INIT_AUTOMAKE(bsnmp-regex, 0.1)
+
+AC_CONFIG_SRCDIR([src/bsnmp-regex.c])
+AM_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LIBTOOL
+
+# Debug mode
+AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],
+ [Compile binaries in debug mode]))
+
+if test "$enable_debug" = "yes"; then
+ CFLAGS="$CFLAGS -g -O0 -Wall"
+ AC_DEFINE_UNQUOTED(_DEBUG, 1, [In debug mode])
+ echo "enabling debug compile mode"
+fi
+
+# Some checks for BSNMP libraries
+AC_CHECK_LIB(bsnmp, snmp_close, ,
+ [echo "Couldn't find the bsnmp module library"; exit 1])
+
+# Checks for header files.
+AC_HEADER_STDC
+dnl AC_CHECK_HEADERS()
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_MEMCMP
+dnl TODO AC_CHECK_FUNCS([atexit inet_ntoa inet_pton memset strerror strspn strtol])
+
+AC_CONFIG_FILES([Makefile src/Makefile])
+AC_OUTPUT