summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e760dba..2f63558 100644
--- a/configure.in
+++ b/configure.in
@@ -13,6 +13,12 @@ AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_LIBTOOL
+AC_CHECK_PROG(GENSNMPTREE, gensnmptree, "gensnmptree")
+if test -z "$GENSNMPTREE"; then
+ echo "ERROR: gensnmptree program not found."
+ exit 1
+fi
+
# Debug mode
AC_ARG_ENABLE(debug,
AC_HELP_STRING([--enable-debug],
@@ -39,6 +45,11 @@ if test "$enable_pcre" = "yes"; then
AC_DEFINE_UNQUOTED(WITH_PCRE, 1, [Use PCRE regular expression library])
fi
+AC_CHECK_HEADERS([sys/queue.h sys/limits.h sys/stat.h sys/time.h sys/un.h], ,
+ [echo "ERROR: required header not found."; exit 1])
+AC_CHECK_HEADERS([bsnmp/snmpmod.h], ,
+ [echo "ERROR: required bsnmp header not found." exit 1])
+
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_TYPE_SIZE_T
@@ -46,7 +57,6 @@ AC_TYPE_SIZE_T
# Checks for library functions.
AC_FUNC_MALLOC
AC_FUNC_MEMCMP
-dnl TODO AC_CHECK_FUNCS([atexit inet_ntoa inet_pton memset strerror strspn strtol])
AC_CONFIG_FILES([Makefile module/Makefile tools/Makefile doc/Makefile])
AC_OUTPUT