summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2005-04-26 19:53:45 +0000
committerStef Walter <stef@memberwebs.com>2005-04-26 19:53:45 +0000
commitd558a844149b8303538a8e7b60f8d5009eaa82d7 (patch)
treeaefd84d482034c71761a39f1b3b7470c953faeeb /configure.in
parent1226811e4aead186d1c94dd190c6a40ea4ec4c2d (diff)
Solaris compatibility patches
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 7f59ab4..2527c67 100644
--- a/configure.in
+++ b/configure.in
@@ -66,12 +66,16 @@ fi
ACX_PTHREAD( , [echo "ERROR: Pthread support not found."; exit 1] )
LIBS="$PTHREAD_LIBS $LIBS"
-CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+CFLAGS="$CFLAGS $PTHREAD_CFLAGS -D_POSIX_PTHREAD_SEMANTICS"
+
+# Some checks for Solaris
+AC_CHECK_LIB(socket, getsockname)
+AC_CHECK_LIB(nsl, getaddrinfo)
# Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS(limits.h,,)
-AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h err.h string.h], ,
+AC_CHECK_HEADERS([limits.h err.h paths.h],,)
+AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h string.h netdb.h], ,
[echo "ERROR: Required C header missing"; exit 1])
# Check for linux type transparent proxy support
@@ -93,10 +97,14 @@ AC_CHECK_DECL(PTHREAD_MUTEX_ERRORCHECK_NP, [AC_DEFINE(HAVE_ERR_MUTEX, 1, "Error
[AC_CHECK_DECL(PTHREAD_MUTEX_ERRORCHECK, [AC_DEFINE(HAVE_ERR_MUTEX, 2)], ,
[ #include <pthread.h> ])], [ #include <pthread.h> ])
+# Required Variables
+AC_CHECK_MEMBER(struct tm.tm_gmtoff,,,[ #include <time.h> ])
+AC_CHECK_GLOBAL(__argv)
+
# Required Functions
AC_CHECK_FUNCS([memset strerror malloc realloc getopt strchr tolower getaddrinfo], ,
[echo "ERROR: Required function missing"; exit 1])
-AC_CHECK_FUNCS([strlwr strlcat strlcpy strncat strncpy])
+AC_CHECK_FUNCS([strlwr strlcat strlcpy strncat strncpy setenv daemon])
# Have to resolve this for the path below
if test "${prefix}" = "NONE"; then