summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2004-09-04 00:05:08 +0000
committerStef Walter <stef@memberwebs.com>2004-09-04 00:05:08 +0000
commitfdafaaeec8b05ab1e62457ecb6202ced98caa202 (patch)
tree3b093585fcce8975acee7b8b5ca5700702821ec6 /configure.in
parent4fb48e235e0f76d3e5fcdd61e88ac63fa46cc14d (diff)
Transparent proxy support.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 636ebbf..452a482 100644
--- a/configure.in
+++ b/configure.in
@@ -36,8 +36,8 @@ dnl Nate Nielsen <nielsen@memberwebs.com>
dnl
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(clamsmtp, 0.7.90, nielsen@memberwebs.com)
-AM_INIT_AUTOMAKE(clamsmtp, 0.7.90)
+AC_INIT(clamsmtp, 0.7.91, nielsen@memberwebs.com)
+AM_INIT_AUTOMAKE(clamsmtp, 0.7.91)
LDFLAGS="$LDFLAGS -L/usr/local/lib"
CFLAGS="$CFLAGS -I/usr/local/include"
@@ -70,9 +70,20 @@ CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
# Checks for header files.
AC_HEADER_STDC
+AC_CHECK_HEADERS(limits.h,,)
AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h err.h string.h], ,
[echo "ERROR: Required C header missing"; exit 1])
+# Check for linux type transparent proxy support
+AC_CHECK_HEADERS([linux/netfilter_ipv4.h],
+ AC_DEFINE(LINUX_TRANSPARENT_PROXY, 1, [Whether the system supports a linux type transparent proxy]),
+ ,
+ [[
+ #ifdef HAVE_LIMITS_H
+ #include <limits.h>
+ #endif
+ ]] )
+
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_TYPE_SIZE_T