summaryrefslogtreecommitdiff
path: root/apache1x/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'apache1x/Makefile.am')
-rw-r--r--apache1x/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/apache1x/Makefile.am b/apache1x/Makefile.am
new file mode 100644
index 0000000..d043935
--- /dev/null
+++ b/apache1x/Makefile.am
@@ -0,0 +1,33 @@
+
+EXTRA_DIST = mod_httpauth.c
+
+DEF=
+INC=-I../ -I../common/
+
+all: mod_httpauth.so
+
+
+mod_httpauth.so: mod_httpauth.c ../common/sock_any.c
+ @APXS@ -c -Wc,-g -Wc,-O0 $(DEF) $(INC) $(LIB) mod_httpauth.c
+
+# install the DSO file into the Apache installation
+# and activate it in the Apache configuration
+install: all
+ @APXS@ -i -a -n 'httpauth' mod_httpauth.so
+
+# cleanup
+clean:
+ -rm -f mod_httpauth.o mod_httpauth.so
+
+# reload the module by installing and restarting Apache
+reload: install restart
+
+# the general Apache start/restart/stop procedures
+start:
+ @APACHECTL@ start
+restart:
+ @APACHECTL@ restart
+stop:
+ @APACHECTL@ stop
+
+