summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 516d69a..f239273 100644
--- a/configure.in
+++ b/configure.in
@@ -72,8 +72,9 @@ AC_CHECK_LIB([c], [crypt], , [
# Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h err.h string.h], ,
+AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h string.h], ,
[echo "ERROR: Required C header missing"; exit 1])
+AC_CHECK_HEADERS([err.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -87,7 +88,7 @@ AC_CHECK_DECL(PTHREAD_MUTEX_ERRORCHECK_NP, [AC_DEFINE(HAVE_ERR_MUTEX, 1, "Error
# Required Functions
AC_CHECK_FUNCS([memset strerror malloc realloc getopt strchr tolower getaddrinfo], ,
[echo "ERROR: Required function missing"; exit 1])
-AC_CHECK_FUNCS([strlwr])
+AC_CHECK_FUNCS([strlwr thr_yield sched_yield pthread_yield daemon])
# LDAP support
AM_CONDITIONAL(WITH_LDAP, test -n "$with_ldap")