summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am21
1 files changed, 15 insertions, 6 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 3d80d4c..7eb7087 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -2,23 +2,32 @@
sbin_PROGRAMS = httpauthd
httpauthd_SOURCES = httpauthd.c httpauthd.h usuals.h bd.h bd.c misc.c basic.h basic.c \
- ntlm.c ntlmssp.h ntlmssp.c digest.h digest.c ldap.c defaults.h simple.c \
- \
+ digest.h digest.c defaults.h simple.c \
../common/compat.h ../common/compat.c ../common/buffer.h ../common/buffer.c \
../common/hash.h ../common/hash.c ../common/md5.h ../common/md5.c \
../common/sha1.h ../common/sha1.c ../common/sock_any.c ../common/sock_any.h \
- ../common/stringx.c ../common/stringx.h \
- \
+ ../common/stringx.c ../common/stringx.h
+
+LDAP_SOURCES = ldap.c
+
+NTLM_SOURCES = ntlm.c ntlmssp.h ntlmssp.c \
smblib/smblib.c smblib/smblib-util.c smblib/file.c smblib/smb-errors.c \
smblib/exper.c smblib/smblib-api.c smblib/smblib.h smblib/std-defines.h \
smblib/smblib-priv.h smblib/smblib-common.h \
- \
rfcnb/rfcnb-io.c rfcnb/rfcnb-util.c rfcnb/session.c rfcnb/byteorder.h \
rfcnb/rfcnb-common.h rfcnb/rfcnb-error.h rfcnb/rfcnb.h rfcnb/rfcnb-io.h \
rfcnb/rfcnb-priv.h rfcnb/rfcnb-util.h rfcnb/std-includes.h
+if WITH_LDAP
+httpauthd_SOURCES += $(LDAP_SOURCES)
+endif
+
+if WITH_NTLM
+httpauthd_SOURCES += $(NTLM_SOURCES)
+endif
+
httpauthd_CFLAGS = -D_THREAD_SAFE -pthread -DLinux \
-I${top_srcdir}/common/ -I${top_srcdir}
httpauthd_LDFLAGS = -pthread
-EXTRA_DIST =
+EXTRA_DIST = $(LDAP_SOURCES)