summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2008-05-02 17:37:49 +0000
committerStef Walter <stef@memberwebs.com>2008-05-02 17:37:49 +0000
commitf717d0236ff400eea0fe4bbd2e57db2f783a1713 (patch)
tree023d2f9cc93f1541be660de4870d86f490b7c872 /configure.ac
parent597d4be9d0dbb4e0ab159c491627767eddc7eb46 (diff)
- Support the multi-ip jail patch that's floating around.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index de431d4..3d97868 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,13 @@ AC_CHECK_LIB([c], [jail], ,
[ echo "ERROR: Must have jail capabilities (FreeBSD 4.x or higher)"; exit 1])
AC_CHECK_LIB([c], [jail_attach],
[ JAIL_ATTACH=yes; ], )
+AC_CHECK_MEMBER([struct jail.ips],
+ [ JAIL_MULTIPATCH=yes; AC_DEFINE_UNQUOTED(JAIL_MULTIPATCH, 1, [Patched Multiple IP support])], [],
+[[
+#include <sys/types.h>
+#include <sys/param.h>
+#include <sys/jail.h>
+]])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -103,3 +110,8 @@ if test "$JAIL_ATTACH" = "yes"; then
else
echo "Your version of FreeBSD (4.0 - 5.0) only supports the old utilities"
fi
+
+if test "$JAIL_MULTIPATCH" = "yes"; then
+ echo "Your version of FreeBSD supports multiple IPs per jail via the patch."
+fi
+