summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..3b34e62
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,33 @@
+# Process this file with autoconf to produce a configure script.
+AC_INIT(jailutils, 0.5.4, nielsen@memberwebs.com)
+AM_INIT_AUTOMAKE(jailutils, 0.5.4)
+
+AC_CONFIG_SRCDIR([src/killjail.c])
+AM_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+
+# Checks for libraries.
+AC_CHECK_LIB([kvm], [kvm_open])
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([syslog.h path.h fcntl.h limits.h sys/param.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+AC_TYPE_PID_T
+AC_TYPE_OFF_T
+
+# Checks for library functions.
+AC_TYPE_SIGNAL
+AC_CHECK_FUNCS([strerror strstr memmove])
+AC_FUNC_MALLOC
+
+AC_STRUCT_TM
+
+AC_CONFIG_FILES([Makefile src/Makefile])
+AC_OUTPUT
+