summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0bbaa44..4789027 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,16 @@ if test "$enable_debug" = "yes"; then
echo "enabling debug compile mode"
fi
+# Static compilation
+AC_ARG_ENABLE(static,
+ AC_HELP_STRING([--enable-static],
+ [Compile binaries in debug mode]))
+
+if test "$enable_static" = "yes"; then
+ CFLAGS="$CFLAGS -static"
+ echo "enabling static compile mode"
+fi
+
# Checks for libraries.
AC_CHECK_LIB([kvm], [kvm_open], ,
[ echo "ERROR: Must have FreeBSD 4.x or higher"; exit 1])