summaryrefslogtreecommitdiff
path: root/module/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2009-06-17 00:13:58 +0000
committerStef Walter <stef@memberwebs.com>2009-06-17 00:13:58 +0000
commita7557acb5423ea8e4c6bcce27472918c638d56f8 (patch)
tree3e3c0e5b811441d1231670ba034be6c4973fdb1d /module/Makefile.am
parent2e1c4b9fc834c8af9f1a31789b1dc614c13fcad5 (diff)
Some coding work. Banged out generally how things will work. Nothing compiles yet.
Diffstat (limited to 'module/Makefile.am')
-rw-r--r--module/Makefile.am38
1 files changed, 12 insertions, 26 deletions
diff --git a/module/Makefile.am b/module/Makefile.am
index b303c5e..7b05ad4 100644
--- a/module/Makefile.am
+++ b/module/Makefile.am
@@ -1,30 +1,16 @@
+noinst_LTLIBRARIES = libmodauthsingleid.la
+noinst_DATA = mod_auth_singleid.la
-EXTRA_DIST = mod_auth_singleid.c
+INCLUDES = -I../ -g -O0 ${APACHE_CFLAGS} ${OPKELE_CFLAGS}
+AM_LDFLAGS = ${OPKELE_LIBS}
-DEF =
-INC = -I../
+libmodauthsingleid_la_SOURCES = \
+ mod_auth_singleid.c \
+ consumer.cc consumer.h \
+ storage.c storage.h
-all: mod_auth_singleid.so
-
-mod_auth_singleid.so: mod_auth_singleid.c
- @APXS@ -c -Wc,-g -Wc,-O0 -Wc,-Wall $(DEF) $(INC) $(LIB) mod_auth_singleid.c
-
-# Install the DSO file into the Apache installation and activate it in config
-install: all
- @APXS@ -i -a -c -Wc,-g -Wc,-O0 $(DEF) $(INC) $(LIB) mod_auth_singleid.c
-
-# Cleanup
-clean:
- -rm -f mod_auth_singleid.o mod_auth_singleid.so
-
-# Reload the module by installing and restarting Apache
-reload: install restart
-
-# The general Apache start/restart/stop procedures
-start:
- @APACHECTL@ start
-restart:
- @APACHECTL@ restart
-stop:
- @APACHECTL@ stop
+install-exec-local:
+ @APXS@ -i -a -n 'authopenid' mod_auth_openid.la
+mod_auth_singleid.la: libmodauthsingleid.la
+ ${APXS} -c -o $@ $< ${APACHE_CFLAGS} ${OPKELE_CFLAGS} ${OPKELE_LIBS}