summaryrefslogtreecommitdiff
path: root/module/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2009-05-12 19:18:38 +0000
committerStef Walter <stef@memberwebs.com>2009-05-12 19:18:38 +0000
commitc7093ba47710804ff8da32dc401fdef7f73171a4 (patch)
tree9651eee46a7c0aa21d16e4f61970d67b271fbc37 /module/Makefile.am
Initial import
Diffstat (limited to 'module/Makefile.am')
-rw-r--r--module/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/module/Makefile.am b/module/Makefile.am
new file mode 100644
index 0000000..b303c5e
--- /dev/null
+++ b/module/Makefile.am
@@ -0,0 +1,30 @@
+
+EXTRA_DIST = mod_auth_singleid.c
+
+DEF =
+INC = -I../
+
+all: mod_auth_singleid.so
+
+mod_auth_singleid.so: mod_auth_singleid.c
+ @APXS@ -c -Wc,-g -Wc,-O0 -Wc,-Wall $(DEF) $(INC) $(LIB) mod_auth_singleid.c
+
+# Install the DSO file into the Apache installation and activate it in config
+install: all
+ @APXS@ -i -a -c -Wc,-g -Wc,-O0 $(DEF) $(INC) $(LIB) mod_auth_singleid.c
+
+# Cleanup
+clean:
+ -rm -f mod_auth_singleid.o mod_auth_singleid.so
+
+# Reload the module by installing and restarting Apache
+reload: install restart
+
+# The general Apache start/restart/stop procedures
+start:
+ @APACHECTL@ start
+restart:
+ @APACHECTL@ restart
+stop:
+ @APACHECTL@ stop
+