summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in39
1 files changed, 39 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..40e6806
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,39 @@
+
+
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(nullpop, 0.1, nielsen@memberwebs.com)
+AM_INIT_AUTOMAKE(nullpop, 0.1)
+
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(nullpop.c)
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LN_S
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS(fcntl.h limits.h paths.h sys/file.h sys/time.h syslog.h unistd.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+AC_HEADER_TIME
+AC_TYPE_UID_T
+
+dnl Checks for library functions.
+AC_FUNC_ALLOCA
+AC_TYPE_SIGNAL
+AC_CHECK_FUNCS(gethostname select socket strdup strerror strstr)
+
+AC_ARG_ENABLE(debug,
+[ --enable-debug enable debugging messages and logging.],
+[
+AC_MSG_RESULT(debugging enabled)
+AC_DEFINE(DEBUG)
+],)
+
+AC_CONFIG_HEADER(config.h)
+AC_OUTPUT(Makefile)