summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-01-26 12:46:14 -0600
committerStef Walter <stefw@collabora.co.uk>2011-01-26 12:46:14 -0600
commit4375e297b19bc2177e17cc5616e75d96be053328 (patch)
treee62b542ae6bb600332912e14c480270709934760 /Makefile.am
parentf8009b4d504de0ed752b867893acd263108409e0 (diff)
Add testing and start testing hash table functionality.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index df12be0..d7e1bc2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
-SUBDIRS = module
+SUBDIRS = module tests
ACLOCAL_AMFLAGS = -I m4
@@ -16,3 +16,13 @@ dist-hook:
else \
echo A git clone is required to generate a ChangeLog >&2; \
fi
+
+if WITH_COVERAGE
+coverage:
+ mkdir -p tests/coverage
+ $(LCOV) --directory . --zerocounters
+ $(MAKE) check
+ $(LCOV) --directory . --capture --output-file tests/coverage.info
+ $(GENHTML) --output-directory tests/coverage tests/coverage.info
+ @echo "file://$(abs_top_builddir)/tests/coverage/index.html"
+endif