summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-01-26 12:46:14 -0600
committerStef Walter <stefw@collabora.co.uk>2011-01-26 12:46:14 -0600
commit4375e297b19bc2177e17cc5616e75d96be053328 (patch)
treee62b542ae6bb600332912e14c480270709934760 /tests/Makefile.am
parentf8009b4d504de0ed752b867893acd263108409e0 (diff)
Add testing and start testing hash table functionality.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..56a5620
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,17 @@
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/module \
+ -Icutest
+
+noinst_PROGRAMS = \
+ hash-test
+
+hash_test_SOURCES = \
+ hash-test.c
+
+hash_test_LDADD = \
+ $(top_builddir)/module/libp11-kit-testable.la
+
+check-am:
+ ./hash-test