summaryrefslogtreecommitdiff
path: root/module/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'module/Makefile.am')
-rw-r--r--module/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/module/Makefile.am b/module/Makefile.am
new file mode 100644
index 0000000..2aba99d
--- /dev/null
+++ b/module/Makefile.am
@@ -0,0 +1,18 @@
+
+INCLUDES = \
+ -DPKCS11_MODULE_PATH=\"$(PKCS11_MODULE_PATH)\"
+
+MODULE_SRCS = \
+ p11-unity.c \
+ hash.c hash.h
+
+lib_LTLIBRARIES = p11-unity.la
+
+p11_unity_la_LDFLAGS = \
+ -module -avoid-version \
+ -no-undefined -export-symbols-regex 'C_GetFunctionList'
+
+p11_unity_la_SOURCES = $(MODULE_SRCS)
+
+EXTRA_DIST = \
+ pkcs11.h \ No newline at end of file