summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..5950e91
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,31 @@
+
+/* TODO: Replace with our own header */
+AC_INIT(module/cryptoki-log.c)
+AM_INIT_AUTOMAKE(cryptoki-log, 0.1)
+
+AC_CONFIG_HEADERS(config.h)
+AM_PROG_LIBTOOL
+
+# Debug mode
+AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],
+ [Compile binaries in debug mode]))
+
+if test "$enable_debug" = "yes"; then
+ CFLAGS="$CFLAGS -g -O0 -Wall -Werror"
+ AC_DEFINE_UNQUOTED(_DEBUG, 1, [In debug mode])
+ echo "enabling debug compile mode"
+else
+ dnl AC_DEFINE_UNQUOTED(G_DISABLE_ASSERT, 1, [Disable glib assertions])
+ echo "disabling debug compile mode"
+fi
+
+AC_CHECK_LIB(dl, dlopen, , [echo "ERROR: libdl not found."; exit 1])
+
+# TODO: We don't need this once we switch to glib
+dnl ACX_PTHREAD( , [echo "ERROR: Pthread support not found."; exit 1] )
+dnl LIBS="$PTHREAD_LIBS $LIBS"
+dnl CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+
+AC_OUTPUT([Makefile pkcs11/Makefile module/Makefile])
+