summaryrefslogtreecommitdiff
path: root/module/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'module/Makefile.am')
-rw-r--r--module/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/module/Makefile.am b/module/Makefile.am
new file mode 100644
index 0000000..ed0a17b
--- /dev/null
+++ b/module/Makefile.am
@@ -0,0 +1,15 @@
+
+MODULE_SRCS = cryptoki-log.c
+EXTRA_DIST = cryptoki-constants.c export.map
+
+lib_LTLIBRARIES = cryptoki-log.la
+cryptoki_log_la_LDFLAGS = \
+ -module \
+ -version-info 0:0:0 \
+ -Wl,--no-undefined \
+ -Wl,--version-script=$(srcdir)/export.map
+cryptoki_log_la_CFLAGS = \
+ -I$(top_srcdir)/pkcs11 -I.
+cryptoki_log_la_SOURCES = $(MODULE_SRCS)
+
+