summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f046226..9a3d42a 100644
--- a/configure.in
+++ b/configure.in
@@ -9,6 +9,15 @@ AM_CONFIG_HEADER([config.h])
AC_PROG_CC
AC_PROG_INSTALL
+# Depend on openssl
+AC_CHECK_LIB(crypto, BN_new, ,
+ [echo "ERROR: Must have openssl library."; exit 1]
+)
+
+AC_CHECK_HEADERS([openssl/rsa.h], ,
+ [echo "ERROR: Must have openssl headers"; exit 1]
+)
+
CFLAGS="$CFLAGS -g -O0 -Wall"
AC_CONFIG_FILES([