summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@thewalter.net>2010-10-28 16:35:36 +0000
committerStef Walter <stef@thewalter.net>2011-01-23 15:47:45 -0600
commit57ccf44dca2905aa85d852177ffa4ad28ccfb9da (patch)
treef803dc2d99803a6ddde6be59f32cbb8b4cec9af3 /configure.in
parentd806a9d9e19ae13ed8dbf4f26dce3c2afdde7c6a (diff)
Transparent proxying without running as root.
Using linux capabilitiy CAP_NET_ADMIN
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 321c0a3..48ca230 100644
--- a/configure.in
+++ b/configure.in
@@ -108,6 +108,13 @@ AC_CHECK_FUNCS([memset strerror malloc realloc getopt strchr tolower getaddrinfo
AC_CHECK_FUNCS([strlwr strlcat strlcpy strncat strncpy strcasestr setenv daemon])
AC_CHECK_FUNCS([getline getdelim])
+# libcap2
+AC_CHECK_LIB([cap], [cap_get_proc], have_libcap="yes", have_libcap="no")
+if test $have_libcap = yes; then
+ AC_DEFINE(HAVE_LIBCAP, 1, [Have libcap2 package, libcap library])
+ LIBS="$LIBS -lcap"
+fi
+
# Have to resolve this for the path below
if test "${prefix}" = "NONE"; then
prefix=$ac_default_prefix