summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@thewalter.net>2006-08-29 17:49:12 +0000
committerStef Walter <stef@thewalter.net>2006-08-29 17:49:12 +0000
commit686ba4ee4b645d27c2d9db568c2f326acb05bc25 (patch)
tree62b90c247f5930497afbfd873f1bbe884701348c /configure.in
parentc8a1522c99afdc3d951949e6eca088d065117bfa (diff)
Add debug compile mode
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 785ca07..f12be30 100644
--- a/configure.in
+++ b/configure.in
@@ -53,6 +53,17 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_AWK
+# Debug mode
+AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],
+ [Compile binaries in debug mode]))
+
+if test "$enable_debug" = "yes"; then
+ CFLAGS="$CFLAGS -g -O0 -Wall"
+ AC_DEFINE_UNQUOTED(_DEBUG, 1, [In debug mode])
+ echo "enabling debug compile mode"
+fi
+
# The maximum buffer size
AC_ARG_ENABLE(BUF,
AC_HELP_STRING([--max-buf=SIZE],