summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2006-01-27 01:29:51 +0000
committerStef Walter <stef@memberwebs.com>2006-01-27 01:29:51 +0000
commit308449c0d80f0473476edc7b6bea4f0691ab042b (patch)
tree4c69e58e965aeb99251c7a35a2e181f5cc3eb56d /configure.in
parent53c0296161ef4c654b026f56685d024d8ed8261d (diff)
Added command line options. See #58
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index f841f18..5f4f5bd 100644
--- a/configure.in
+++ b/configure.in
@@ -10,13 +10,13 @@ AM_CONFIG_HEADER([config.h])
# Debug mode
AC_ARG_ENABLE(debug,
- AC_HELP_STRING([--enable-debug],
- [Compile binaries in debug mode]))
+ AC_HELP_STRING([--enable-debug],
+ [Compile binaries in debug mode]))
if test "$enable_debug" = "yes"; then
- CFLAGS="$CFLAGS -g -O0"
- AC_DEFINE_UNQUOTED(_DEBUG, 1, [In debug mode])
- echo "enabling debug compile mode"
+ CFLAGS="$CFLAGS -g -O0"
+ AC_DEFINE_UNQUOTED(_DEBUG, 1, [In debug mode])
+ echo "enabling debug compile mode"
fi
dnl Check for programs.
@@ -37,6 +37,13 @@ AC_HEADER_STDC
AC_CHECK_HEADERS([rrd.h], , [echo "ERROR: rrd headers not found"])
dnl TODO: AC_CHECK_HEADERS
+# Have to resolve this for the path below
+if test "${prefix}" = "NONE"; then
+ prefix=$ac_default_prefix
+fi
+
+AC_DEFINE_UNQUOTED(CONF_PREFIX, "`eval echo ${sysconfdir}`", [Installation Prefix] )
+
AC_MSG_RESULT()
AC_CONFIG_FILES([Makefile