summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2009-10-24 14:10:25 +0000
committerStef Walter <stef@memberwebs.com>2009-10-24 14:10:25 +0000
commit9145a2db71a85064aa6a198c44da3cf753241131 (patch)
treefaa3a1a60475f9e6810a3f6618593d430cc61511 /configure.in
parent082ac8f970f9c2cb244ffccc7b382b259e7b4f69 (diff)
Fixes for OpenSolaris 0906
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 17aa8ed..8281dbd 100644
--- a/configure.in
+++ b/configure.in
@@ -47,18 +47,23 @@ CFLAGS="$CFLAGS $PTHREAD_CFLAGS -D_POSIX_PTHREAD_SEMANTICS"
dnl Checks for libraries
AC_CHECK_LIB(rrd, rrd_update, ,
[echo "ERROR: librrd not found."; exit 1])
+dnl May need these for getaddrinfo
+AC_CHECK_LIB(nsl, nis_lookup)
+AC_CHECK_LIB(socket, getaddrinfo)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_C_INLINE
+AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])
dnl Check for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([rrd.h], , [echo "ERROR: rrd headers not found"])
-AC_CHECK_HEADERS([unistd.h stdio.h stddef.h stdlib.h assert.h errno.h stdarg.h string.h netdb.h], ,
+AC_CHECK_HEADERS([unistd.h stdio.h stddef.h stdlib.h assert.h errno.h stdarg.h string.h netdb.h ], ,
[echo "ERROR: Required C header missing"; exit 1])
+AC_CHECK_HEADERS([sys/socket.h sys/cdefs.h])
-AC_CHECK_FUNCS([strlcat strlcpy strtob])
+AC_CHECK_FUNCS([daemon strlcat strlcpy strtob strncasecmp strcasestr])
AC_CHECK_FUNCS([strerror getopt getaddrinfo], ,
[echo "ERROR: Required function missing"; exit 1])