summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2006-01-28 00:17:38 +0000
committerStef Walter <stef@memberwebs.com>2006-01-28 00:17:38 +0000
commitfbfb057e8bed90f73850d8e871e4d70e8fa705ce (patch)
tree920c2a626ddd185176d1d8c14be7b1d7497451d1 /configure.in
parentae2e52d578ca1dd78e31beed4c63a9b17ce3bb60 (diff)
Standardize the string functions and search for them properly when configuring on different OSs.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ba89937..6438116 100644
--- a/configure.in
+++ b/configure.in
@@ -35,7 +35,12 @@ AC_C_INLINE
dnl Check for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([rrd.h], , [echo "ERROR: rrd headers not found"])
-dnl TODO: AC_CHECK_HEADERS
+AC_CHECK_HEADERS([unistd.h stdio.h stddef.h stdlib.h assert.h errno.h stdarg.h string.h netdb.h], ,
+ [echo "ERROR: Required C header missing"; exit 1])
+
+AC_CHECK_FUNCS([strlcat strlcpy strtob])
+AC_CHECK_FUNCS([strerror getopt getaddrinfo], ,
+ [echo "ERROR: Required function missing"; exit 1])
AC_MSG_RESULT()